
 

 

ePMV: INTRODUCTORY TUTORIALS July 2011                         NBCR Workshop 
Written by Graham Johnson 
Made possible by Ludovic Autin, Graham Johnson, David Goodsell, Michel Sanner & Arthur Olson 

http://epmv.scripps.edu  Download free, install, tutorials, gallery, forum 
embedded Python Molecular Viewer (ePMV) runs molecular modeling software directly inside of 
professional 3D animation applications (hosts) to provide simultaneous access to the capabilities 
of these newly connected systems. Uniting host and molecular toolkit functionalities into a single 
interface, allows illustrators to quickly create common representations of molecular models and 
to perform computational simulations, like molecular dynamics, directly inside of a host’s 
viewport with relative ease. 
   Available free at http://epmv.scripps.edu, ePMV currently supports Blender, Cinema4D, and 
Maya. It should soon support Houdini, Sketchup, 3D StudioMax, RealFlow, SoftImage, etc. 

Quickstart Activities 
I. Basics 1:  Build a PDB file representation in a Professional 3D application with 2 mouse clicks 

A. Start C4D 
B. Open ePMV GUI 

1. Click the ePMV button in the top palette (green/orange ribbon)  

a) Or access it via C4Dmenu: Python>Plugins>ePMV 
C. Get a Molecule (using ePMV GUI) 

1. Click [Fetch] to get 1crn (the box comes filled with this 4‐digit PDB code by default) 

2. You have a ribbon model of the protein Crambin (PDB ID code 1crn) 
D. Build Atoms 

1. Unfold Atoms/Bond Representation 

2. Check [ ]Atoms radio box 
a) Here we can see all of the atoms in the PDB file with their canonical IUPAC 
colors 

E. Zoom in on scene 

1. Hover mouse over viewport and type H on keyboard 
F. Study model 

1. Click and drag viewport icons (upper right) to rotate camera, pan, zoom, etc. 
2. Turn Atoms on and off as you explore to compare to the underlying ribbon. (check 
and uncheck the []Atoms radio box) Leave Atoms on when you’re done. 

G. Align view to defaults to match instructor screen 

1. ViewportMenu>Edit>FrameDefault 

2. Hover over viewport and type H to center and zoom again 
H. Render the molecule (command R) 

I. Expand to 4 panel view  
1. Click upper right viewport icon 
2. Zoom each of 4 panels 

a) Hover mouse over each panel and hit H each time 

3. Render all four panels  
a) Command R while mouse hovers over each panel one at a time 

J. Experiment with each of the different Color by scheme: <options> 

1. In the Object Manager: 



a) Unfold 1crn 
b) Unfold 1crn:A 
c) Unfold 1crn:A_cpk to expose the instances of each atom on the molecule 
and to understand the hierarchy format 

2. In the ePMV GUI: 

a) Unfold Color by 
b) Try each menu pulldown and witness changes to the molecule and to the 
material manager 

K. Beautify 
1. Open Render Settings 

a) Effects>AmbientOcclusion 

b) Render to see results 
2. Speed up 

a) Set Acc=20%, Min=8, Max=32 

b) Render 
3. Uncheck specular for all materials 

a) Double‐click the first material 

b) Hover mouse over Material manager 

c) Hit command A to select all materials 

d) Uncheck Specular in the Material Editor 

e) Render 
L. Save your Cinema 4D file 

1. C4D menu: File>Save file as… 

2. 1crnSpaceFillAO1.c4d to a new folder you make on the desktop 
M. Add a text signature 

1. C4D menu: Mograph>MoText 

2. Set Text box = yourNam 

3. Set Depth = 1, and Height = 3  
4. Position and rotate to a visible location 

N. Render a JPG 
1. Render settings (C4D menu: Render>RenderSettings:  

a) Output>Preset: 800x600 
b) Output>Frame Range: Current Frame 
c) Save>File: Browse to the folder you created for the file to create a new file 
path with .jpg name 

d) Save>Format: JPG 

2. Render with PictureViewer to save a file (Click Center Clapboard) 
O. Share your signed creation with the world 

1. Upload JPG to ePMV gallery by following instructions 

2. Add a caption to your online gallery image with a description and credits 

P. Save this final incarnation of your C4D file  
1. File>Save (command S) 

II. Basics 2: model a ribbon representation 
A. Turn atoms off 

B. Build a Basic PMV‐style Ribbon 



C. Unfold Backbone Representation 
D. Check [ ] Ribbon to build (you may already have a ribbon that was built by the new default 
when you first loaded 1crn) 

E. Explore color options 
1. Try all o f the color options  

a) Many schemes either don’t work in this beta version or are meaningless on a 
ribbon representation.  

2. When finished exploring, choose Color by scheme: [rainbow] 
a) Some schemes, like rainbow, currently work with limited functionality on 
ribbons, coloring from N term to C term in reverse ROYGBIV 

F. Choose Color by scheme: [secondary structure] 

G. We will now work with molecules in a familiar interface 

1. Change a default color: 
a) Double click the first hot pink material in the Material Manager 

b) Change the blasted pink to a blue of your choosing 
c) Unfold the hierarchy to expose the coils, strands, and helices in 1crn:A_ss 
d) Material Manager>Function>Render All Materials 

e) See in the Object Manager how this changes the applied material 

2. Override a default color 
a) Create a new material in the material manager 

b) Change it from white to green 

c) Drag the new green material onto the other pink helix in the viewport 
d) Note in the Object manager how this retains the original pink material, but 
overrides it with a second green material on top of it (to the right). 

H. Add a point light to the scene (Objects>Scene>Light) 
1. Drag it up on Y to about 50 (grab the green handle and pull up) 
2. Set Z to ‐20 
3. Command R to render viewport 

I. Add a fill light and an ambient light 

1. Object>Scene>Light   
a) Do this twice, or duplicate the light by control dragging in the Object 
Manager to make two lights 

2. Select on of the lights 
a) Double click to rename it Key Light 

b) Move it to your favorite Key Light position 

3. Select the other light 
a) In the attributes manager, check [ ] Ambient Illumination 

b) Reduce intensity to ~30 
4. Render to test your lights 
5. Tinker with the lights and colors for 3 minutes 

J. Render a JPG and post it to the gallery 
III. Quickstart Basics 3: Upgrade to a Fancy Ribbon Model 

A. Uncheck [ ]Ribbons 
B. Check [ ] Beaded Ribbons 
C. Click [Options] (right of beaded ribbon) 



D. Experiment with huge palette of settings for 5 minutes 

1. Use your glossary as a guide if you want 
E. Render a JPEG and post to the gallery 

IV. Quickstart basics 4: Add a transparent surface 
A. With fancy ribbon still visible 

B. Make an MSMsurface 

1. Unfold Surface representations 
2. Check [ ] MSMSurf 

C. Experiment with Surface Colors 

1. Unfold Color by 
a) Try all of the colors. 

2. Set Pulldown to Scheme: Atoms using CPK 

3. Render view to see result  
4. Set Pulldown to Scheme: AtomsDG (polarity/charge) 

5. Render view to see result 
D. Make the AtomSurface coloring transparent 

1. Double Click the first Material named “_Blue” to open the Material Editor 

2. Shift select the “_Red” and “_Green” 
3. In Material Editor check Transparency 

4. Scroll 20% up to 60  
E. In RenderSettings>AmbientOcclusion, click evaluate transparency 

1. Render 
V. Quickstart basics 5: Animate a Ribbon‐in‐Surface Turntable Rotation 

A. In Object Manager, select 1crn (topmost parent null) 

B. Set playback head to zero using VCR controller  

1.  
C. Uncheck Translate, Scale and Parameter Key record options next to Key button (lower right) 
so only Rotate is blue as shown below. 

1. . 

D. Click the [Key] button   

E. Set VCR to end at frame 90 

F. In Coordinate Manager in H box type 360‐360/90 

1. Make sure H says 356, then hit [Apply] 
G. Click the [key] 
H. Hit VCR play 
I. Linearize the anchors to make a clean rotation 

1. Open timeline 

2. Select anchors 
3. In Attribute Manager change Interpolation: <Spline> to <Linear> 

J. Set up to render an animation in the RenderSettings 

1. Output: FrameRange = All Frames 

2. Save: Format = Quicktime Movie 



3. Options = Compression = H.264, Qulity = ~60%. 
K. Render the movie as a quicktime with H264 60% compression 

L. Post to the gallery when it finishes and meanwhile work on next project. 

M. Save file 
VI. Build the Biological Unit representation of a protein file: 

A. Restart C4D and then ePMV 

B. ePMV menu>Edit>Options: 

1. deselect [ ] Center molecule, [ ] Remove water, and [ ] PMV camera 

2. Click OK and close the options window 
C. Get Molecule: enter the 4 digit ID 2plv and click [Fetch] 

D. ePMV menu>Edit>Biological Unit 

E. Type 2plv and click OK 
1. Wait patiently 
2. 60 copies of the original asymmetric unit have been replicated to form the entire 
viral capsid for polio virus‐ an icosohedral (soccer ball) sphere 

3. Explain what instances are and how to efficiently swap them 
F. Color by <chain> and note the patterns of pentamers and hexamers that emerge at different 
vertices 

G. Change the chain colors either with Edit>Color Palettes, or in the Material Manager 

H. Fiddle with the settings, try a coarseMolSurf  

1. If you build an MSMS, set the triangles to 1 instead of 3 BEFORE checking [ ]MSMS 
I. Render and post to the gallery. 

VII. NMR 2kzy 
A. Restart C4D 
B. ePMV menu>Edit>Options: 

1. deselect [ ] Center molecule, [ ] Remove water, and [ ] PMV camera 

2. Click OK and close the options window 
C. Fetch 2kzy 
D. Check [ ] Lines 
E. Unfold Data Player 
F. Click the pulldown that says 2kzy.mo… and drag to 2kzy.model to reinitialize the data player 

1. The Grey slider bar below should move to zero at the left 
G. Scroll back and forth to see the different states (represented by your line model) in the 
viewport… there are 20 possible states (the last two of the 21 states are redundant) 

H. Don’t try to animate this with simple interpolation‐ because it the nonsequential states will 
result in major clashes as the molecule collapses through itself… wait for the MD animation 
tutorial. 

VIII. Loading a transmembrane PDB file 
A. Edit>Options, uncheck [ ] Center molecule and check [ ] Force Downloading 

B. Type 1f88 into the box and select OPM from the dropdown then hit Fetch 

C. Check [ ] Atoms  

D. Follow instructor to apply to a surface. 



IX. Loading a volumetric file (3D density map) derived from single‐particle Electron 
Microscopy 

A. Visit the Electron Microscopy Data Base 

1. Click Basic Search 
2. Type nuclear into the Title box on the search page and hit the [start search] button 
3. Click on entry 1097 
4. Click Map Information 

5. Click to download then unzip emd_1097.map.gz 

B. CHANGE emd_1097.map to emd_1097.ccp4 (bug in PMV doesn't recognize the .map tag) 

C. Open ePMV 

D. Load a molecule, e.g., 1crn to trigger needed functions (temporary glitch we'll fix soon) 

1. This dummy molecule need not be visible, but its good to leave on to get an idea of 
the major scale differences between a tiny protein like 1crn (crambin) and your 
relatively large Nuclear Pore Complex 

E. Unfold DataPLayer 
F. In Data Player panel, Browse to your .ccp4 file to load it 

1. Since the file is formatted with proper headers, the map will load at a correct scale 
compared to any molecules in the scene (often shockingly large) 

G. Zoom out to see your nuclear pore complex surface map 

1. Hover over viewport and Type H… you’ll be shocked by the size difference. 
H. Adjust your data slider to approximately 2.6 (better to type then to slide, but play around 
since this is a large file) 

I. Now you can center the molecule to the origin, generate a large sphere to mock up a 
nucleus, and I'll show you how to map the nuclear pore to your fake sphere nucleus in a 
separate tutorial for Cinema 4D. 

X. Apply the nuclear pore to a mock nucleus 
These Cinema4D‐specific instructions are generalizable to skilled users of other host software 
like Maya and Blender) 

A. Generate a 3D isocontoured surface model using ePMV in the 1st part of this tutorial 

B. Reduce the Polygon Count on your molecule 

1. C4D top menu Object>Deformer>PolygonReduction 
2. In the Object Manager panel, drag the new PolygonReduction deformer onto 
'yourLoadedDummyMoleculeName'IsoSurface to make it a child of 
yourLoadedDummyMoleculeName'IsoSurface 
3. Right click on 'yourLoadedDummyMoleculeName'IsoSurface and select Current 
state to object 
4. After the new object is created below the original, delete the original (and its child 
Polygon Reduction Deformer 

C. Center your nuclear pore complex about the origin of the scene. 

1. Select your reduced polygon mesh in the Object Manager 

2. Click on the PointTool button (in the left‐most palette in C4D's default layout) 
3. Hover in the viewport and Select all of the points Command A on a mac, Control A 
on a PC 

4. In the Coordinates manager, set all values to zero and click [Apply] 
5. In the Coordinates manager, type ‐90 in the H box and ‐300 in the Y box and click 
[Apply] 



D. C4D top menu Object>Primitive>Sphere 

E. With the sphere selected, in the attributes manager, change Radius=8000, Segments=3, and 
Type=Icosohedron 

F. Double click the sphere in the object manager to change its name to 
mockNucleusOuterMembrane 

G. C4D top menu Mograph>Cloner 

H. With Cloner selected, set Mode=Object and drag mockNucleusOuterMembrane sphere from 
the object manager into the Object box in the Cloner attribute manager 

I. In the object manager, drag yourLoadedDummyMoleculeName'IsoSurface onto the Cloner to 
make it a child of the cloner. 

J. Click on Cloner and change Distribution=Surface 
K. Click on mockNucleusOuterMembrane and change segments=24 

L. Create a new material and drag it onto mockNucleusOuterMembrane 

M. Hack a hole into the outer membrane 

1. Double click the material name to change it to Nuc 
2. Double click the mockNucleusOuterMembrane material icon to open the Material 
Editor 

3. Check the [ ] Alpha box and in the Alpha box details: 
4. Check [ ] Invert 
5. Set the Texture pulldown menu to Effects>Proximal 

6. Click Proximal (spherical gradient box) to edit its details in the Material Editor Alpha 

7. Drag Cloner from the object manager into the big Objects area box 

8. Set Start Distance=410 and End Distance=500 
N. Render your scene 
O. Play with adding bump maps with noise and transparency, etc. 

P. Try adding a Displacer Deformer as a child of mockNucleusOuterMembrane with noise 
scaled to ~3000 and height to ~200 to make the sphere more organic. 

1. This works fine for mocking up a nuclear membrane, from outside of the nucleus, 
but recall that its actually a double membrane (like a continuous spherical 
Endoplasmic Reticulum that is fenestrated by the nuclear pores. 
2. If you plan to fly close to or inside of your nucleus you may need to temporarily 
replace your pores with cylinders, duplicate the sphere and reduce that spheres radius 
to mock the inner bilayer, then boolean to remove the spheres, etc.  

XI. Install Modeller and play with realtime dynamics 
A. Download Modeller to your desktop 

1. http://salilab.org/modeller/download_installation.html 

2. ePMV menu Extensions>AddAnExtension 

3. paste into the box 
a) modeler:Users/yourcomputerUserName/Desktop/modeler‐9v9/modlib/ 

b) Click OK 
4. Restart ePMV 

XII. Basic realtime MD 
A. ePMV options: 

1. Uncheck all 
2. Check [ ] Synchro realtime 



3. Check [ ] Modeller 
B. Browse and search for 1tim 

1. Load 1TIMtr.pdb 

2. Verify that the Molecule is named 1TIMtrm in the Object Manager 
C. Add a Synchronization tag (temporary bug requires this step) 

1. Select 1TIMtrm in the Object manager 

a) Object Manager menu: Tags>PythonTags>epmvSynchro 
D. Turn on Modeller and set it up 

1. ePMV menu: Extension>Modeller 

2. check [ ] realtime, [ ] display, and change mini to md 
E. Play 

1. Click on an atom and drag it 

2. Follow the instructor to set up an IK chain. 


